4,308 Commits over 1,552 Days - 0.12cph!
Return defaults in a bunch of functions I don't want to deal with yet
Impl Create Shapes in interface, looks like these are just used for temp shapes
Give physics shape a owner body
Remove UpdateSphereShape and UpdateCapsuleShape from interface, unused
body SetPosition and SetOrientation
Do the same but from serialized rubikon mesh and hull data (ugh)
Set body shape after shape is created
Impl AddSphereShape
Imp AddCapsuleShape
Remove MarkCallstack and MarkCallstackSkeleton
Remove GetOwnerDebugName
Impl physics body get shape (jolt only has 1 shape per body so I guess will need to get subshapes from compounds?)
Remove interacts with and as nonsense
Remove GetBroadphaseProxy
Impl physics shape type
Remove GetBaseInteractsAs from interface, no longer used
Debug names for body and shape
Impl PositionIterations and VelocityIterations
Give physics shape a jolt shape
Impl physics body GetWorld
Physics body motion type get/set
Get pos and rot of physics body
Impl physics world debug name
Impl GetActiveBodyCount and GetActiveBodies
Set allow sleeping on body settings
Save world reference body
Get body count
Impl GetBody
Set jolt body user data to our body
Create jolt body when we add body to the world
Give physics world a user data
physics device name
Save physics world create flags
Save physics simulation type to apply to bodies later, I don't think jolt can set simulation mode as a whole
Add physicscasts to convert between jolt and source units
Change physics world GetGravity to return non const because we need to return local vector
Impl CJoltPhysicsInterface::GetWorld
Impl CJoltPhysicsInterface::Draw
Impl CJoltPhysicsInterface::SetVisualDebugCameraHint
Keep a list of worlds in jolt physics interface
Implement CreateWorld and DestroyWorld
CJoltPhysicsWorld stubs
Create managed handle for physics body and world
Renaming - keep everything tidy
Assert all unimplemented functions in physics interface
CJoltPhysicsBody stubs
CJoltPhysicsShape stubs
Remove duplicate precompiled header
Add new jolt files to vpc
Move rubikon/profile.h to physicslib, we don't want to be including rubikon shit in interfaces
Update jolt to latest
Get this shit compiling again
Merge branch 'jolt-physics' into jolt_physics2
Rename vphys2_aggregate to physicsaggregate
Remove CRnContact usage in IPhysicsShape
Merge IVPhysXWorld into IVPhysics2World, I don't see the point of having two world interfaces other than to be annoying
Trim some more functions from physics world
Don't link vphysics2 in face poser, I don't think it's needed
Remove unused vphys2 convars
Rename CVPhys2World to CPhysicsWorld for consistency
Remove CRnWorld usage out of physicsdebugdraw
Remove physicsdefinitions
Remove IFnPhysicsSoftbody
Remove Type dispatch functions from physics joint interface
Remove IFnPhysicsBaseShape
Remove some unused functions from physics body interface
Animgraph: Hide gizmos and ground plane when in viewmodel camera mode
Remove IFnPhysicsHullShape and IFnPhysicsMeshShape